Snowplow Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter · #1 ·
Do any of you use the rubber boot over the pump that Meyer sells? I get one with my new pump purchase. I don't know if this does any good or not. It seems like it could trap salt in there unless it really does seal everything out.
Thanks,
Andy
 

·
Registered
Joined
·
6,272 Posts
I use one with my new pump and i just leave the bottom open not to trap any water.
 

·
Registered
Joined
·
610 Posts
i was going to buy one for my e60

the dealer said their a pia if you have a problem
because when its cold the cover gets hard
john
 

·
Registered
Joined
·
150 Posts
I think its worth the time to get it off if you have problems ,because the E-60 always as have trouble with water getting inside them.
 

·
Registered
Joined
·
1,741 Posts
I think they're great. I put them on 3 or 4 years ago & haven't had any of the usual Meyer repair problems since. Before that, well you all that own them already know what I'm talking about, spent more time fixing them than moving snow LOL ;) :headwall
The way they are mounted allows water to escape the bottom, so they aren't completely sealed. I also haven't experienced frozen oil problems since then, but would have to deal with that every once in a while before that. A theory we had was that not only does the cover keep snow from getting packed onto the unit, but it probably helps keep some of the natural heat that it generates from escaping.
 

·
Registered
Joined
·
610 Posts
guys
im sold ill be ordering one tommorrow
john
 
1 - 6 of 6 Posts
Top