Snowplow Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I follow this site for useful info, but I exhausted my options so I’m posting my first post. Bought a newer Silverado 2500hd. Came with a western mpv plus vplow with a ultra mount 2. Worked great until the fleet flex remote power light started to blink. While checking that out I saw a spark and realized the power harness that runs into the truck that plugs into the controller had the positive wire pulled out of the connector and was exposed. It must of bumped something metalthat made it short out. Really not sure what it hit but it did short out because it was exposed and I saw the flash. Now I had 2 issues. Light blinking and the plow in the up position running constantly even when controller wire and the light connector in the grill was disconnected. Only way to shut down the motor was to disconnect the grill power connector to the plow. So did all the recommendations. Replaced the selanoid checked fuses and checked the two relays. I even bought a aftermarket controller that was for the plow . One relay did rattle when I shook it which made me think it was bad. So I replace both with new ones. Powered it up still the same the pump kept running and the light was blinking. But this time the arm went down from the up position. Just wanted to look over it again before giving up and noticed the positive wire going to the selanoid was looked a bit discolored and not sure if there was a short originally before this night mare started. Before taking it to the nearest western dealer just want to see if anyone else has anything else I could check before I spend coin letting the dealer look at it. Read somewhere the issue could be the plow side module.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 · (Edited)
Yea. I have. I even bought a “new” used controller harness that goes through the firewall. No luck. I think the only next logical option is to bring it to the experts at the dealer. Use to plow when I was younger, know how to plow but know nothing about plows themselves. Options and patients have been exhausted. All the reading i have done and what I Replaced that wasn’t the problem seems to lead to one thing. The 3 port module on the plow is fried. But before making that purchase I want someone who knows what they are doing to determine if that is what the definite fix is.
 

·
Registered
Joined
·
522 Posts
it's definitely the plow side module - and that wire shorting out could absolutely be what fried it. Obviously replace that power cable before replacing the module.
 
1 - 5 of 5 Posts
Top