Snowplow Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #3
they are all good, I and getting power too the controller plug but the controller is old my thinking is that is the problem las year shake the controller before it would work, just wondering if that could be all it is and new controller might be the solution
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
i will it is an older Western snow plow maybe around late 90's early 2000 I had power to the controller plug but the controller itself but the power light didn't even come on .now the plow motor des work in I jump the pump motor right from the battery
 

·
Registered
Joined
·
682 Posts
the bad controller didn’t fix it self over the summer??? I’d write somebody a nasty gram.

Are you saying the pump motor doesn’t work when you jump or bypass the system or does not work.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #8
when use jumper cables and connect directly from the battery the pump motor will rum but blade wont move and I have power too the controller plug but the controller power light and buttons will do nothing . thinking about the problem more and remembered last winter a few time in order to get the controller to work I had wiggle the controller wire to make it work , I had forgotten about that my short term memory is bad had a stroke and being 77 mind tends too forget somethings. I tank you for your help and taking time to give me some ideas . have a Merry Christmas and best of the New Years. tomorrow the new part comes l I will let you know what happens
 

·
Registered
Joined
·
6 Posts
Discussion Starter #9
the bad controller didn’t fix it self over the summer??? I’d write somebody a nasty gram.

Are you saying the pump motor doesn’t work when you jump or bypass the system or does not work.
the bad controller didn’t fix it self over the summer??? I’d write somebody a nasty gram.

Are you saying the pump motor doesn’t work when you jump or bypass the system or does not work.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #10
when I jump the snow plow pump i had for motor directly to the battery the motor runs , but no movement to the blade. and I have power from the battery to the controller plug. there is no power too the controller the power light doesn't even come on. I had forgotten last year a couple of time I had to shake the controller for the power to come on. I had a stroke toward the end of plowing and bring 77 so short term memory is somewhat gone, anyway thanks for listening to my problem. Have a Merry .Christmas and best of New Years tomorrow I get the new part I will let you know
 
1 - 10 of 10 Posts
Top