Snowplow Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
400 Posts
Discussion Starter · #1 ·
Well I have another one for ya, I have a 2000 F350 lariat, 4dr, sb srw 5.4 gas. The overhead console display quit working, it is the small box above the rearview mirror that has the outside temperature, the average fuel mileage, and a compass, yesterday it was working, today I started the truck and nothing, it wont come on, everything else is fine all the fuses are good ???

Any thoughts or recommendations?


Mike
 

·
Registered
Joined
·
43 Posts
There is a seperate fuse for that, may want to start there. However, if it was working one day and you changed nothing electronically in the truck something else may have happened.

Good Luck !!:shades
 

·
Registered
Joined
·
8,442 Posts
inop

You can check the fuses like M&F suggested however to check this part of the system really requires a scanner has the overhead display works threw the GEM module i would also add that the overhead units have had there fair share of problems with the newer f series trucks i would be careful but check the wiring has it runs down threw the pillar and a post of the truck the ground is on the left side behind lower panel near ebrake pedal you could check that has well.
 

·
Registered
Joined
·
163 Posts
Mike;

Check to make sure that you didn't accidently push the button to turn the display off.

I have the same overhead console in my 1999 Expedition and I think that if you cycle through the different display options, one of them ends up with a blank display ("off").
 

·
Registered
Joined
·
400 Posts
Discussion Starter · #5 ·
Thanks,

I've checked all the fuses, the unit itself to see if it was off and if the wireing was correct everythings good.

I guess its time to take it to the shop:headwall


Mike
 
1 - 5 of 5 Posts
Top