Snowplow Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hello I have a question about my E60 pump. On the front right under the celluloids are two plugs and the one was leaking so I dug into my Harbor Freight collection of Viton O-rings and replaced it because the original was shot. Well I was feeling pretty good about it because I thought I fixed the leaking problem but I was wrong so I got the wrench out and tightened it up some and it made it worse. The o-ring I replace it with sure looked like a match but evidently not does anyone know where I can buy a o-ring specific for this plug? Maybe I should try doubleing up on the o-ring or maybe adding a flat washer. I looked on line at some parts diagrams but they don't show the plugs or the o-rings. Thanks for any help you can provide.

Mark
 

·
Registered
Joined
·
1,569 Posts
Hello I have a question about my E60 pump. On the front right under the celluloids are two plugs and the one was leaking so I dug into my Harbor Freight collection of Viton O-rings and replaced it because the original was shot. Well I was feeling pretty good about it because I thought I fixed the leaking problem but I was wrong so I got the wrench out and tightened it up some and it made it worse. The o-ring I replace it with sure looked like a match but evidently not does anyone know where I can buy a o-ring specific for this plug? Maybe I should try doubleing up on the o-ring or maybe adding a flat washer. I looked on line at some parts diagrams but they don't show the plugs or the o-rings. Thanks for any help you can provide.

Mark
https://www.smithbrothersplowparts.com/store/index.php?l=product_detail&p=7122

Check these guys out... they started the site about 19 years ago...
 

·
Registered
Joined
·
228 Posts
Hello I have a question about my E60 pump. On the front right under the celluloids are two plugs and the one was leaking so I dug into my Harbor Freight collection of Viton O-rings and replaced it because the original was shot. Well I was feeling pretty good about it because I thought I fixed the leaking problem but I was wrong so I got the wrench out and tightened it up some and it made it worse. The o-ring I replace it with sure looked like a match but evidently not does anyone know where I can buy a o-ring specific for this plug? Maybe I should try doubleing up on the o-ring or maybe adding a flat washer. I looked on line at some parts diagrams but they don't show the plugs or the o-rings. Thanks for any help you can provide.

Mark
I think you need #21999, its a new plug and o-ring, there should be little filters in behind the plug, remove and clean them, there are two. One in front, and one in the back.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Thanks Walter and DD. Yeah I was on their site and saw the plug and o-ring I was just hoping to find just the o-ring, evidently the o-ring I used was to small I'm going to try a copper washer and double up on the O-rings and if that doesn't work I'll have to buy the drain plug. Dieseldude did you say there are two filters behind this drain plug?

Mark
 

·
Registered
Joined
·
1,569 Posts
Thanks Walter and DD. Yeah I was on their site and saw the plug and o-ring I was just hoping to find just the o-ring, evidently the o-ring I used was to small I'm going to try a copper washer and double up on the O-rings and if that doesn't work I'll have to buy the drain plug. Dieseldude did you say there are two filters behind this drain plug?

Mark
Mark,

I don’t use meyers plows so that was the closest I could find to having just the o ring.
 
1 - 7 of 7 Posts
Top