Snowplow Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter · #1 ·
Just got a new tranny that shifts sweet, but..

Now I get an intermittant "service engine soon" light. Did the paper clip thing (94 K1500) and got code 13, o2 sensor.
I've read alot about blocked catalytic converters and how they can cause performance problems, but does anyone know if a blocked converter could cause this?


Thanks fro the heads up Chris...;)


thanks
-e
 

·
Registered
Joined
·
8,323 Posts
Code 13 is for an intermittant open oxygen sensor circuit.

It is usually caused by a bad O2 sensor.

Due to the recent tranny work being done.I would carefully check al wiring to the O2 sensor and make sure everything is OK.Maybe something got damaged during the removal of the tranny.

Also check and make sure the O2 ground is clean and tight,maybe it got left off,or loose.It is usually a tan wire connected to the engine block.I believe it's at the back of one of the cylinder heads somewhere.

Check that stuff first,if you don't find anything,let me know,and we can go through some of the diagnostics to narrow it down some more.

Oh,and welcome to the new site :D
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #3 ·
Thanks, I'll check it out as soon as I get a chance..
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #4 ·
I found a sensor on the driver side header right at the spot where all four tubes come together. It's not connected to anything.
Anyway, I'm not getting a SES light right now, do I have to reset the "brain" to have the SES light come on again? Should it be connected somehow to the ECM?


Thanks...
-e
 
1 - 4 of 4 Posts
Top