Snowplow Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have an older RT3 PowerV that when cold does not have power. No controller, lights, plow, anything. If I leave truck running it eventually will work and work fine. Controller kicks on, lights switch from truck to plow, plow functions. The colder it is, the longer the truck has to "warm up" before plow kicks in. On warmer days it kicks right in.

It seems like maybe a solenoid or relay problembut can't seem to pin point it. Relay is new. My plow mechanic can't seem to figure it out either. Any suggestions are appreciated.
Truck is a 2003 GMC 2500HD. I bought truck with plow installed.

Thanks
G
 

·
Registered
Joined
·
371 Posts
When it is not working, you need to check for power, instead of a test light use a headlamp bulb, this will draw more power and make a more defined test of the circuit, If that is good, clean all of your grounds, do not just assume something is clean, Take the connections off and clean them. And get a new plow mechanic.
 

·
Registered
Joined
·
6 Posts
I would start with all power and ground connections. theres a key on power source that could be linked to something stupid. i've seen a cyloinoid do something like that but not in a long time. if you have the harness with 4 or 5 in it start swaping them around. only one really does power the others are just lights and turns.If non of that work, buy a remote start then it will be warm when you get in.
 
1 - 3 of 3 Posts
Top