Snowplow Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hello All,

Scatching my head here trying to figure out what happened. I have a 3 plug system on my truck. Plugged everything worked great. Was doing a job today and pushed into a snow bank. Raised the plow and as i was backing the headlights on the plow shut off, toggled the truck head lights back on, and the controller has no power. I checked all fuses and everything seems good. none of the fuses have blown and everythign is exactly how it was when it was working.

I guess my first question is do the headlights turn on plow side if the controller isnt plugged in? I was thinking that maybe it was the controller. I have a fishstik if that helps.

If the motor died for some reason, the headlights would still work in theory correct?

When i unplug the 11 pin connector and reconnect the truck lights flash for a very split second. But wont toggle the headlights. Would a bad bulb cause power loss? I have the older sealed beam lights (will be repalced with intensifire in a few days when they get here.)

But as it sits the plow is stuck in the air. Cant be controlled.

Any help would be greatly appreciated.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
So I did check that. It has power. I wired it into the cigratte adapter using an add a circuit. That gets power still and the fuses are all set none of them blown. So if the controller is bad, do the headlights not toggle? sorry i just dont understand whole system fully.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
No power to the controller at all. I went out and tinkered with it some more. When I unplug the headlight harness the headlights begin to flash on the truck. Once i unplug any of the plugs on the isolation module they return to normal and stop flashing. I checked all the grounds and they seem good. I even swapped iso modules and it does the same thing. The module originally installed on the truck was purchased only 3 weeks ago. The wiring and everyhing is brand new as well.

When i unplug the ground wire (orange and black) off the solenoid the headlights on the truck turn off. So i assume the grounds are all set on that front.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
Also when the plow is plugged in the headlights on the truck stop flashing and return to normal. But it wont switch over to the plow.
 
1 - 7 of 7 Posts
Top