Snowplow Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
71 Posts
Discussion Starter · #1 ·
Guys I have a couple questions on my fisher EHP cable setup.

Im trying to get it all working properly (bought it out of want-ads)
and I've run into 2 problems so far.

The first is one of the quick connects for the angle cyl appears to be wrong. The male side on the angle cylider hose is longer than the male side thats on the pump. So the hoses dont connect together when the plow is off and much more importanly I cant connect that hose to the EHP :confused:

I am guessing the guy needed a fitting and took mine and left that other on there to seal it. What is the style of the fitting
I looked on mcmaster carr and they listed a pioneer and I thnk NPT styles for the hyd fittings with the positive stop in them.

second questions is the plow lifts when angled and when lifted.
I have adjusted the cables to the EHP (per the manual)
but it suggests I need to adjust the check valve and lift valves
ok well the check vlave is easy enough (both vlavesare set at right where the factory starting point is), but the lift valve is an allen socket and the size appears to be between 1/4" and 5/16" or between 6mm and 8mm I guess 7mm or 9/32" So you say well I have looked thru the vast resources availible to me at work and could find no such sizes ie 7mm or 9/32"

is it a 1/4" and just reall loose fit ? the cap screw is in good condition not all rusted etc..

is it just lifting cuz the angles hoses are dissconected or out of adj

:headwall <- me last nite

Dean
 

·
Registered
Joined
·
908 Posts
Dont feel bad about banging your head on the wall, those old cable control pumps do that to a lot of people.

The quick couplers are 1/4 NPT. They should come in a matched set so you should replace both sides.

Did you checked to make sure that the 3 way valve is in the proper position and is traveling correctly? Is the cable stretched? The adjustment of the lift valve is very touchy, sometimes more than an 1/8th of a turn can be to much, so its easier to adjust this with two people. One to run the controls and one to make adjustments. It should be a standard size allen wrench (1/4 if i remember right).

Good luck, hope you get it set right.
 

·
Registered
Joined
·
71 Posts
Discussion Starter · #3 ·
yup thequick connects were 1/4 NPT got them at Carquest. They had a lot of snowplow stuff hoses, shoes, fittings, e motor, etc

I haven't had a chance to look at the lift valve yet I will over the holidays.

thanks

Dean
 

·
Registered
Joined
·
71 Posts
Discussion Starter · #4 ·
Ok I got it all ironed out. once I had a helper I could see the cables were connected wrong. Just switched them and adjusted for length and everything works good.

Dean
 
1 - 4 of 4 Posts
Top