Snowplow Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
went out plowing and stopped for coffee when i got back in the truck the remote had lost connection to the receiver bought the plow new in 07 and in 15 had to upgrade to procontrollerII from Basher worked good till yesterday. remote is full charge even plugged it in in the truck still nothing, any ideas?
 

·
Registered
Joined
·
1,587 Posts
went out plowing and stopped for coffee when i got back in the truck the remote had lost connection to the receiver bought the plow new in 07 and in 15 had to upgrade to procontrollerII from Basher worked good till yesterday. remote is full charge even plugged it in in the truck still nothing, any ideas?
Is there a reset procedure? Maybe you should re-pair it to the plow?


https://www.snoway.com/pro-control-ii-programming-pairing/
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
i pulled the cover off and found the 10 amp fuse blown put in a new fuse raised the plow and drove it home lowered the plow and the fuse blew again tried again same thing not sure if it's a coil or valve problem, tried to pull the B coil was very tight on valve checked the A coil and it slid right off not sure if it is the coil or the valve parts are pricey to buy and there is no longer a dealer close emailed Basher Equip. in PA today but haven't heard back yet.
 

·
Registered
Joined
·
231 Posts
Work the plow, see if you can isolate what function is blowing the fuse. Pick up a re settable circuit breaker
at the auto parts store so you do not have to keep replacing fuses.
 

·
Registered
Joined
·
1,587 Posts
i pulled the cover off and found the 10 amp fuse blown put in a new fuse raised the plow and drove it home lowered the plow and the fuse blew again tried again same thing not sure if it's a coil or valve problem, tried to pull the B coil was very tight on valve checked the A coil and it slid right off not sure if it is the coil or the valve parts are pricey to buy and there is no longer a dealer close emailed Basher Equip. in PA today but haven't heard back yet.
https://www.snoway.com/wp-content/uploads/2018/12/97101382D.pdf

Check this out it might help you out.
 

·
Registered
Joined
·
98 Posts
If the coil is hard to get off 8ts due to the valve swelling. More then likely the swollen valve caused damage to the coil causing the protective layer to come off or get damaged letting water in and shorting out the positive signal
 

·
Registered
Joined
·
2 Posts
My wireless remote for snoway plow light is red, it’s fully charged and the red light is flickering on the board. I’ve tried pairing,light flickers red and green then goes back to flicking red. Is there something else I can do?
 

·
Registered
Joined
·
1,587 Posts
check the batteries in the remote? I know you say it is charged but is it possible one of the batteries is not giving you full voltage?
 
1 - 10 of 10 Posts
Top