Snowplow Forums banner
1 - 13 of 13 Posts

· Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
I plowed a short (0.5 mile) dirt road today into a camp that I always plow, When I got to the end I was in the snow bank a little bit when I raised the plow and it caused some resistance as I raised it.. Didn't think much of it but when I got home my plow wouldn't go down. It goes side to side with ease but when I push the down button nothing happens, The light on the controller turns from green to red to symbolize that it is in float but the plow stays up. When I push up, the motor bogs like it is allready all the way up (which it is..) I tried putting the plow in float and rocking it and even jumping on it but it won't come down.

Whats up with this???? Thanks....
 

· Registered
Joined
·
9 Posts
Discussion Starter · #2 ·
kinda funny I just noticed we have a thread titled "boss plow won't lower" and one right under it titled " boss plow will not lift" I guess Id rather have mine stuck up than down, at least I can drive the truck like this.. Any help is greatly appreciated though. Thanks
 

· Registered
Joined
·
747 Posts
Snow has probably bumped your wiring connector to the point that those pins are not making contact, yet the others are. Check that first - it happens to me about twice a season when backblading heavy accumulations.
 

· Registered
Joined
·
362 Posts
My controller was doing the same thing, but i could get it to lift and drop sometimes. Brought it to the dealer, tested everything, narrowed it down to the controller. A new one fixed it. If you know someone that also has a BOSS, try their controller, a Vee will work on a straight blade, just make sure you press the angle buttons in the middle or the blade will move opposite.
 

· Registered
Joined
·
9 Posts
Discussion Starter · #5 ·
I checked the wireing, unplugged and plugged it back in, still won't go down. I tried loosening the flow control valve like the boss trouble shooting directions say and that seamed to do noghtin. I put it back where it was since it worked fine before. I don't think its the controller just because its been working perfect and showed no signs of problems before this. I have a boss dealer nearby so I'll try and get him to look at it in

Anyone got anymore ideas?? We have gotten about 6 inches of snow in the last 4 hours and I have to plow a funeral home out in the morning for a funeral. I really need this plow...
 

· Registered
Joined
·
9 Posts
Discussion Starter · #7 ·
Im gunna take it to our closest boss dealer first thing in the morning, I'll see if he has another controller he can put on mine and see if that is the problem.. We have gotten about 10 inches of fresh snow in the last 7 hours.. I hope I can get this thing working early tomorrow or Im screwed for plowing... I gotta get a backup truck...
 

· LetsTalkSnow.com - SPONSOR
Joined
·
2,178 Posts
Did you take the cover off and see if a wire got pulled or fell off of the solenoid valve?


DINO... I can't reply to your request because your PM mailbox is full
 

· Registered
Joined
·
9 Posts
Discussion Starter · #10 ·
Did you take the cover off and see if a wire got pulled or fell off of the solenoid valve?


DINO... I can't reply to your request because your PM mailbox is full
Hit the nail right on the head my friend... Thats exactly what it was. I simply did not have time to work on it and I have never had the cover off it so I didn't even know what I was gunna see when it came off. I had a funeral to go to (got someone else to plow out the funeral home for me) and I had to work 12 hour shifts so I was simply out of free time. I took it to our closest boss dealer and he fixed it for me for $55. Not too bad I didn't think since I had it back in about 2 hours. He said it was a wire off the solenoid under the cover..

Thanks for all the help guys. I'll definately be back on here for more help... Thanks again!!!
 

· Registered
Joined
·
1 Posts
I plowed a short (0.5 mile) dirt road today into a camp that I always plow, When I got to the end I was in the snow bank a little bit when I raised the plow and it caused some resistance as I raised it.. Didn't think much of it but when I got home my plow wouldn't go down. It goes side to side with ease but when I push the down button nothing happens, The light on the controller turns from green to red to symbolize that it is in float but the plow stays up. When I push up, the motor bogs like it is allready all the way up (which it is..) I tried putting the plow in float and rocking it and even jumping on it but it won't come down.

Whats up with this???? Thanks....
 

· Registered
Joined
·
1 Posts
Hello All,

I just want to drop a message to thank everyone on this thread. Today my BOSS plow would not raise.

I just took the cover off the pump and sure enough it was a wire on the solenoid came off. Tightened it up and put it back on and all is good.

Thanks for posting your resolution to the problem as it cut my troubleshooting down to nothing!

IceBoss
 
1 - 13 of 13 Posts
Top