Snowplow Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
Well I looked at a 350...junk.So I am stuck with the 327.The problem is she idles like a dream, put it in gear it has no power.I have changed the wires, coil ,modulator,plugs.Checked the compression cold she is 60lbs warmed up she is 90lbs on 1-2 cylinders.Set timing to 0 and 8' advanced.Still no power when I try and drive it she just spit ,sputters and stalls.I have been told everthing from cam to heads to just plan done....It has been converted over to HEI Ignition.And my oil pressure is 25lbs idle goes up to 40lbs when I rev it.:confused:
 

·
Registered
Joined
·
3,937 Posts
Just a wild guess, it almost sounds like the timing chain jumped a notch.No power,low compression across the board.If it has a cat convertor,id un hook the exhaust and see if it runs better first. With a timing light onthe engine if the chain is real loose you can see the timing mark jump around a lot. Also your igntion timing could be a bit late too.
 

·
Registered
Joined
·
192 Posts
shane

Did you check to make sure the distributor isn't in 180° backwards?? :headwall I did this back in 1973 with a Corvette ;) pulled & turn it 180° and all was well:D
 

·
Registered
Joined
·
8,323 Posts
Sure does sound like a timing chain.

Put a socket on the crank bolt with a breaker bar,and turn the engine back and forth while watching the dist rotor.If you have to turn the engine a fair ways to get the rotor to move,the chain is pretty loose,and probably jumped a tooth.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #5 ·
timing chain movement

The movement is about 3/4 of an inch before rotor moves.It is a '66 327 small journal crank.And is a pain:headwall .Not sure of movement specs.
 

·
Registered
Joined
·
8,323 Posts
That's not as bad as I though it would be.Still could have jumped a tooth.Only way to tell for sure is to remove the timing cover.
 

·
Registered
Joined
·
1,352 Posts
0 deg initial and 8 total advance is way low.....unless I am missunderstanding ya?

oil pressure is fine
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #8 ·
advance

I stopped at 8 she seemed to idle best there.And that is when I checked compression and it was only 60psi at first then I ran it and compression went up to 90psi...So that is when I stopped trying advance and gave up......I checked specs and found my compression should be at least 159psi.That would explain my power loss:headwall ...So now I found a 305 price was right ...just so I can get it moving, rebuild the 327 and try next year:mad: This simple project with the son has really started to cost me some money:) .I am just glad it is not my daily driver:burnout
 

·
Registered
Joined
·
1,352 Posts
rings are probably shot

Small journal sbc's are a rare breed depending on what it is out of. Might see about selling it to an auto resore buff and geting a regular old 350 or making a 327 outa a 350 block if you want to keep a 327.
 
1 - 9 of 9 Posts
Top