Blizzard 810 help - Snow Plow Forum -†Let's Talk Snow Discussion Forums

 
LinkBack Thread Tools Display Modes
post #1 of 7 Old 01-18-2019, 04:35 PM Thread Starter
Junior Member
 
Join Date: Jan 2019
Posts: 3
Blizzard 810 help

So I have a blizzard 810 on the power hitch 1. It sat for a bit. Cleaned out the resevoir. New filters and seals. Replaced the truck side and plow side wire harness. Added a new motor and a new control box. Unit gets power. Can go left. Can go right. Wings can extend and retract. I just can’t get it to go up. Any suggestions or ideas?
Jakdanwhiskey is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 01-18-2019, 04:40 PM
Member
 
Join Date: Dec 2018
Posts: 39
Do you have the power hitch switch on the control box set properly?
If you put it to power hitch can you operate the toggle switch on the Aframe?
Knucklebusta is offline  
post #3 of 7 Old 01-18-2019, 04:46 PM Thread Starter
Junior Member
 
Join Date: Jan 2019
Posts: 3
Quote:
Originally Posted by Knucklebusta View Post
Do you have the power hitch switch on the control box set properly?
If you put it to power hitch can you operate the toggle switch on the Aframe?
Yes it works fine when I’m power hitch mode it latches to the frame. When in normal operation it allows me to go left right and down but not u
Jakdanwhiskey is offline  
post #4 of 7 Old 01-18-2019, 05:03 PM
Member
 
Join Date: Dec 2018
Posts: 39
S6 is raise.
Pin 10 which is white on the truck side harness is raise. Looks to be in between the main power and ground pins.
Same on the plow side except it's a double wire.
The diode harness maybe bad as well, that is what allows you to use the power hitch switch.
It's a diode pack that needs to be tested with a meter
Knucklebusta is offline  
post #5 of 7 Old 01-18-2019, 05:08 PM
Member
 
Join Date: Dec 2018
Posts: 39
Wiring diagrams are on blizzardplows.com parts and service, library, owners manuals, plows, either ph1, or plows prior to 05 will do
Knucklebusta is offline  
post #6 of 7 Old 01-18-2019, 05:14 PM Thread Starter
Junior Member
 
Join Date: Jan 2019
Posts: 3
Quote:
Originally Posted by Knucklebusta View Post
S6 is raise.
Pin 10 which is white on the truck side harness is raise. Looks to be in between the main power and ground pins.
Same on the plow side except it's a double wire.
The diode harness maybe bad as well, that is what allows you to use the power hitch switch.
It's a diode pack that needs to be tested with a meter
Quote:
Originally Posted by Knucklebusta View Post
Wiring diagrams are on blizzardplows.com parts and service, library, owners manuals, plows, either ph1, or plows prior to 05 will do
So the diode pack came with the new plowside harness. The power hitch switch works fine opens and closes the unit to the frame. The wire harness has no power on the volt meter when engaging the up function. All the way back to where the joystick/controller box connects
Jakdanwhiskey is offline  
post #7 of 7 Old 01-19-2019, 03:27 AM
Member
 
Join Date: Dec 2018
Posts: 39
I would try a nonled test light to be sure.
Could be a micro switch inside that's bad. I would take apart the controller and do a continuity check on the switch
Knucklebusta is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snow Plow Forum -†Let's Talk Snow Discussion Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Help!!! Need Photos Of Bobcat Toolcat With A Blizzard 810 itsgottobegreen Snowplowing Discussions 6 09-14-2006 03:03 AM
New Blizzard 810 Joey D Blizzard Snowplows 24 11-07-2004 02:22 PM
u edge for blizzard 810 REED384 Blizzard Snowplows 31 02-24-2004 04:37 PM
Hey guys, check out this 810 Blizzard PROMOWER Blizzard Snowplows 19 02-18-2004 07:40 PM
Will a Blizzard 810 power plow fit this truck? Plower737 Blizzard Snowplows 11 02-11-2004 04:30 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome