western ultramount headlamps - Snow Plow Forum - Let's Talk Snow Discussion Forums

 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 07-11-2018, 05:47 PM Thread Starter
Junior Member
 
Join Date: Jul 2018
Posts: 3
western ultramount headlamps

i bought a 1996 chevy tahoe with an straight blade ultramount. the controls work well, but the plow headlamps and turn signals dont work, it stays with the truck lights. it has a 4 port isolation unit. i downloaded the schematics. i found what looks like 2 headlamp connectors that were unplugged, under the hood, near the iso unit. connecting them didnt help. there is a purple wire looks like it was cut. connecting that didnt help. there is also a brown wire that looks like it was never used. see pics. the schematic shows two relays, but i cant find them. i thought they might be in the isolation unit, but it looks like they are external.i have not been able to locate them. i hate to say it, im pretty good with schematics, but this one has me stumped. it believe its an hb3/4 system. from the picture in the western manual, it looks like the plugs in the uploaded pic is the short plug in harness? thy look like headlamp plugs, but what about the turn and park lights. if i remember right, brown is park, purple is one of the turns? it looks like part of the correct schematic is page 33, the other page 60. is there a relay module under the dash? im new to this, and need to be pointed in the right direction. thanks much, mike
Attached Thumbnails
Click image for larger version

Name:	20180710_184242.jpg
Views:	26
Size:	47.3 KB
ID:	29546  
mhooker32 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snow Plow Forum - Let's Talk Snow Discussion Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
headlamps not working mhooker32 Western Snowplows 0 07-11-2018 05:44 PM
Mating Connector -- Boss Headlamps?? BB64 Lighting & Wiring 1 12-04-2008 09:44 AM
Western UltraMount on new Chevy looneytune Western Snowplows 17 11-24-2008 07:21 AM
Western UltraMount Removal Question. Honest Mike Western Snowplows 17 02-15-2006 09:02 AM
Silverstar headlamps BWhite Off Topic 4 05-07-2004 05:41 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome