Western snowplow pump moving left and right but not up and down - Snow Plow Forum -†Let's Talk Snow Discussion Forums

 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 11-26-2018, 02:25 PM Thread Starter
Junior Member
 
Join Date: Nov 2018
Posts: 1
Western snowplow pump moving left and right but not up and down

The fluid is new, the plow worked this morning for ahwhile parked it and it wouldn't raise again. Pulled the hose that enables the up and down to work. It makes the noise but doesn't pull the plow up unless I help it with the jack. If i raise it with he jack it grabs at sometimes and work for ahwhile. Please I need help!! Suggestions ideas I could try would appreciate anything thanks
Josh Cameron is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snow Plow Forum -†Let's Talk Snow Discussion Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Sno way plow raise lower but no left to right Darren Zoldos Sno Way Plows 0 11-11-2018 02:04 PM
Hiniker 2802C no up/down/left/right thehathaways Other Snowplow Brands 0 02-06-2018 03:45 PM
MM2 only angles left not right newbie1276 Fisher Snowplows 8 03-01-2009 05:07 PM
Plow Fine Up and Right But Slow Left... Beast12 Arctic Plows Forum 8 11-30-2007 02:51 PM
Left wing slow, sounds low in fluid but its not Hsnow Boss Snowplows 5 10-23-2004 07:56 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome