Pump issues - Snow Plow Forum - Let's Talk Snow Discussion Forums
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 11-16-2018, 11:16 AM Thread Starter
Junior Member
 
Join Date: Nov 2018
Posts: 3
Pump issues

I believe my pump is ****e the bed.
Im in Canada. Im wondering if there is a rebuild kit. Do they do the trick. Are they straight forward to do.
Where I can find the parts online
Also one side of the valve spool seems very tight.
Probably just o-rings ??

Thanks. Hopefully there's enough info.

Sent from my SM-G935W8 using Tapatalk
nel44 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 11-17-2018, 03:37 PM Thread Starter
Junior Member
 
Join Date: Nov 2018
Posts: 3
Well no help here

Sent from my SM-G935W8 using Tapatalk
nel44 is offline  
post #3 of 4 Old 11-18-2018, 06:36 PM
Senior Member
 
WalterFGBS's Avatar
 
Join Date: Sep 2018
Location: Catskill Mountains, NYS
Posts: 580
Garage
Quote:
Originally Posted by nel44 View Post
Well no help here

Sent from my SM-G935W8 using Tapatalk
More information is needed to find the solutions...
WalterFGBS is offline  
post #4 of 4 Old 11-19-2018, 01:10 PM Thread Starter
Junior Member
 
Join Date: Nov 2018
Posts: 3
Quote:
Originally Posted by WalterFGBS View Post
More information is needed to find the solutions...
All good.. got my hands on a second system.
Value bank. Pump
New cables.
I believe the issue was the value bank..
But I didn't have time to check.
I just swapped out the whole thing.
Up and running.
Ill rebuilt the other valve bank for a back up.
When i got the pump off.. i plugged the out line with my finger and spun by hand.. i couldn't keep my finger on it. So probably ok.
Not sure though

Sent from my SM-G935W8 using Tapatalk
nel44 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snow Plow Forum - Let's Talk Snow Discussion Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Lift Pump Issues - 2004.5 Dodge Cummins Diesel crashz Diesel Boys 20 02-15-2010 06:23 AM
95 chevy blazer heat issues (??) D&T Repair Chevy & GMC Trucks 6 01-27-2004 08:45 AM
1973 GMC Tranny Issues Ilyushin 73 - 87 Chevy & GMC Trucks 1 12-23-2003 06:29 AM
hydro clutch issues urethane dino 73 - 87 Chevy & GMC Trucks 9 12-18-2003 03:51 PM
Noaa Issues Winter Outlook Update jt5019 Weather Discussions 13 11-28-2003 12:06 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome