Meyers E60 - Snow Plow Forum - Let's Talk Snow Discussion Forums
 
LinkBack Thread Tools Display Modes
post #1 of 7 Old 11-02-2019, 05:33 PM Thread Starter
Junior Member
 
Join Date: Nov 2019
Location: Fowler Ohio
Posts: 3
Meyers E60

Hello I have a question about my E60 pump. On the front right under the celluloids are two plugs and the one was leaking so I dug into my Harbor Freight collection of Viton O-rings and replaced it because the original was shot. Well I was feeling pretty good about it because I thought I fixed the leaking problem but I was wrong so I got the wrench out and tightened it up some and it made it worse. The o-ring I replace it with sure looked like a match but evidently not does anyone know where I can buy a o-ring specific for this plug? Maybe I should try doubleing up on the o-ring or maybe adding a flat washer. I looked on line at some parts diagrams but they don't show the plugs or the o-rings. Thanks for any help you can provide.

Mark
oleblu72 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 11-03-2019, 04:48 AM
LetsTalkSnow.com - Addict
 
WalterFGBS's Avatar
 
Join Date: Sep 2018
Location: Catskill Mountains, NYS
Posts: 1,182
Garage
Quote:
Originally Posted by oleblu72 View Post
Hello I have a question about my E60 pump. On the front right under the celluloids are two plugs and the one was leaking so I dug into my Harbor Freight collection of Viton O-rings and replaced it because the original was shot. Well I was feeling pretty good about it because I thought I fixed the leaking problem but I was wrong so I got the wrench out and tightened it up some and it made it worse. The o-ring I replace it with sure looked like a match but evidently not does anyone know where I can buy a o-ring specific for this plug? Maybe I should try doubleing up on the o-ring or maybe adding a flat washer. I looked on line at some parts diagrams but they don't show the plugs or the o-rings. Thanks for any help you can provide.

Mark
https://www.smithbrothersplowparts.c..._detail&p=7122

Check these guys out... they started the site about 19 years ago...
WalterFGBS is online now  
post #3 of 7 Old 11-03-2019, 02:54 PM
Member
 
dieseldude's Avatar
 
Join Date: Dec 2018
Posts: 121
Quote:
Originally Posted by oleblu72 View Post
Hello I have a question about my E60 pump. On the front right under the celluloids are two plugs and the one was leaking so I dug into my Harbor Freight collection of Viton O-rings and replaced it because the original was shot. Well I was feeling pretty good about it because I thought I fixed the leaking problem but I was wrong so I got the wrench out and tightened it up some and it made it worse. The o-ring I replace it with sure looked like a match but evidently not does anyone know where I can buy a o-ring specific for this plug? Maybe I should try doubleing up on the o-ring or maybe adding a flat washer. I looked on line at some parts diagrams but they don't show the plugs or the o-rings. Thanks for any help you can provide.

Mark
I think you need #21999, its a new plug and o-ring, there should be little filters in behind the plug, remove and clean them, there are two. One in front, and one in the back.
dieseldude is offline  
post #4 of 7 Old 11-03-2019, 03:16 PM Thread Starter
Junior Member
 
Join Date: Nov 2019
Location: Fowler Ohio
Posts: 3
Thanks Walter and DD. Yeah I was on their site and saw the plug and o-ring I was just hoping to find just the o-ring, evidently the o-ring I used was to small I'm going to try a copper washer and double up on the O-rings and if that doesn't work I'll have to buy the drain plug. Dieseldude did you say there are two filters behind this drain plug?

Mark
oleblu72 is offline  
post #5 of 7 Old 11-03-2019, 03:23 PM
LetsTalkSnow.com - Addict
 
WalterFGBS's Avatar
 
Join Date: Sep 2018
Location: Catskill Mountains, NYS
Posts: 1,182
Garage
Quote:
Originally Posted by oleblu72 View Post
Thanks Walter and DD. Yeah I was on their site and saw the plug and o-ring I was just hoping to find just the o-ring, evidently the o-ring I used was to small I'm going to try a copper washer and double up on the O-rings and if that doesn't work I'll have to buy the drain plug. Dieseldude did you say there are two filters behind this drain plug?

Mark
Mark,

I don’t use meyers plows so that was the closest I could find to having just the o ring.
WalterFGBS is online now  
post #6 of 7 Old 11-03-2019, 03:34 PM
Member
 
dieseldude's Avatar
 
Join Date: Dec 2018
Posts: 121
There is one filter in the front, and I think one in the rear of the unit.
dieseldude is offline  
post #7 of 7 Old 11-04-2019, 05:01 PM Thread Starter
Junior Member
 
Join Date: Nov 2019
Location: Fowler Ohio
Posts: 3
Ok Dieseldude I understand now thanks.

Mark
oleblu72 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snow Plow Forum - Let's Talk Snow Discussion Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome