Spark at Neg Battery Terminal - Snow Plow Forum - Let's Talk Snow Discussion Forums

 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 03-13-2017, 04:28 PM Thread Starter
Junior Member
 
Join Date: Jan 2017
Posts: 2
Spark at Neg Battery Terminal

I had to change my battery recenlty,

Just connected plow and when trying to raise up first time there was a spark at neg terminal.

removed, cleaned wires, tightened cables down better, tried it again, first time it sparked, worked fine afterwards. going back out in a little bit to look at other connections on solenoid.

Is the spark just the rest of the crud on cables clearing off or possibly something feeding back?

Thank you,

Steve
unicorncomputer is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snow Plow Forum - Let's Talk Snow Discussion Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Loose Negative Terminal On Pump? kelpike Curtis Plows 1 01-03-2009 11:08 AM
So I broke the ground terminal festerw Western Snowplows 4 10-15-2007 09:38 AM
battery terminal spray protector apik1 Lighting & Wiring 25 10-04-2007 10:46 AM
BIG terminal crimpers on the cheap Alan Lighting & Wiring 5 08-24-2005 08:32 PM
'95 no spark scl Chevy & GMC Trucks 4 08-28-2004 07:53 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome