Plow Trouble - Snow Plow Forum - Let's Talk Snow Discussion Forums
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 11-06-2016, 07:23 AM Thread Starter
Junior Member
 
Join Date: Oct 2016
Location: CT
Posts: 2
Plow Trouble

I just replaced the solenoid on my MM1. The valves click when I move the joystick up/down/left/right but no movement in the plow. I jumped the solenoid to check the pump motor and without moving the joystick the pump motor engaged and the plow angled to the left and stayed there and the motor didn't disengage until i disconnected the jumper cables. Any ideas?
tugboat is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snow Plow Forum - Let's Talk Snow Discussion Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
snoway plow trouble bedrock1 Sno Way Plows 7 01-26-2015 11:01 AM
Trans Trouble Darby Creek 73 - 87 Chevy & GMC Trucks 6 03-31-2010 11:09 AM
Artic plow pump trouble triton 1 Arctic Plows Forum 1 02-29-2008 09:13 PM
Trouble w/ truck C75 Chevy & GMC Trucks 2 10-23-2006 04:56 PM
I know I could get in trouble for this gslam88 Off Topic 10 11-02-2004 07:51 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome