MM2 only angles left not right - Snow Plow Forum - Let's Talk Snow Discussion Forums
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-01-2009, 04:24 PM
Junior Member
 
Join Date: Nov 2008
Location: fall river mass.
Posts: 12
MM2 only angles left not right

fixing to get a foot of snow tonight have a brand new mm2 goes up down angles left no problem wont angle right plow has never been used and stays in garage
checked fluid full tried to bleed cylinder very little air now im out of daylight and ideas plus its cold inhere any help appreciated
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 03-01-2009, 04:29 PM
snowjoker's Avatar
LetsTalkSnow.com - Addict
 
Join Date: Nov 2003
Location: Waterport, NY
Posts: 3,379
Check your connections, I bet its either at the plug or a lose wire.....
__________________
Walt
95 Jeep YJ 760 Speedwing
90 Dodge W250 CTD Blizzard 810
Harder Electri-Spread SS v box
1946 Oshkosh W-307 12' Viking one way, 8' Frink V
Reply With Quote
  #3  
Old 03-01-2009, 04:35 PM
Junior Member
 
Join Date: Nov 2008
Location: fall river mass.
Posts: 12
checked all connections motors turns when u hit switch but if u push blade with switch engaged you can move yourself
Reply With Quote
  #4  
Old 03-01-2009, 04:45 PM
atgreene's Avatar
LetsTalkSnow.com - Addict
 
Join Date: Nov 2003
Location: Mud City, Sebago, Maine
Posts: 5,476
Check all your electro valves, see if they have all the wires on them. May be a bad ground on the one for angle, but I sooner think it's still a bad connection on the 3 pin connector. The multi pin connector handles the lights, the connector with just 3 pins handles the angle and lift.

With the truck just sitting, not pressing any button can you angle the plow?

When you angle the right button it works fine until it reaches full right, but then won't go left?

Plow raises normally?
__________________
2013 GMC 3500 9 2 Boss V
2005 GMC 5500 Topkick 10' Boss V, SS Swenson Tailgate Sander, converted to electric (For Sale)
1963 Oshkosh 10' V, 11' Wing (For Sale)
2005 Takeuchi 135
IAFF Local 740

Facebook: A. T. Greene Excavation & Snowplowing

www.atgreene.com
Reply With Quote
  #5  
Old 03-01-2009, 04:49 PM
Junior Member
 
Join Date: Nov 2008
Location: fall river mass.
Posts: 12
Thumbs up

goes all the way left driver side wont go right pass. side no matter what if plow is in air left piston very sloppy moves in and out couple of inches if you push button right on control motor just spins no movement
Reply With Quote
  #6  
Old 03-01-2009, 04:52 PM
atgreene's Avatar
LetsTalkSnow.com - Addict
 
Join Date: Nov 2003
Location: Mud City, Sebago, Maine
Posts: 5,476
And you have oil?

Sounds like you have a screen problem, or are air bound.

Do you have more oil and have you checked your oil?
__________________
2013 GMC 3500 9 2 Boss V
2005 GMC 5500 Topkick 10' Boss V, SS Swenson Tailgate Sander, converted to electric (For Sale)
1963 Oshkosh 10' V, 11' Wing (For Sale)
2005 Takeuchi 135
IAFF Local 740

Facebook: A. T. Greene Excavation & Snowplowing

www.atgreene.com
Reply With Quote
  #7  
Old 03-01-2009, 04:58 PM
Junior Member
 
Join Date: Nov 2008
Location: fall river mass.
Posts: 12
Thumbs up

checked oil bled cylinder dont understand bought 09 silverado with plow they installed plow and drove home been siiting in garage since truck has 250 miles bought 2 months ago never used or hooked up since worked fine at dealership had friend come over he has 3 mm2 on trucks and said he thought it was valve in pump staying open not letting pressure build up
p.s how do you like tb135 looking at buying one
Reply With Quote
  #8  
Old 03-01-2009, 05:07 PM
atgreene's Avatar
LetsTalkSnow.com - Addict
 
Join Date: Nov 2003
Location: Mud City, Sebago, Maine
Posts: 5,476
It's been a good machine.

So you can build pressure to the left, but not to the right? Seems odd. Maybe a bit of crud in the valve, you can pop the cover and pull each one, wipe it off, make sure it's clean, put it back. Make sure you do one at a time, keep track of the wires and keep it clean.

If it wasn't building pressure it wouldn't lift. Each valve does multi functions. Right and lift? are on the same series of valves. I could go check, I have all this written down out in the garage.

If you need more help, let me know, I can run out to the garage and grab my diagrams and try to talk you through a couple tests. That, or someone who knows Fisher better than I can do it from memory.
__________________
2013 GMC 3500 9 2 Boss V
2005 GMC 5500 Topkick 10' Boss V, SS Swenson Tailgate Sander, converted to electric (For Sale)
1963 Oshkosh 10' V, 11' Wing (For Sale)
2005 Takeuchi 135
IAFF Local 740

Facebook: A. T. Greene Excavation & Snowplowing

www.atgreene.com
Reply With Quote
  #9  
Old 03-01-2009, 05:07 PM
snowjoker's Avatar
LetsTalkSnow.com - Addict
 
Join Date: Nov 2003
Location: Waterport, NY
Posts: 3,379
I had a stuck valve on a unimount one time and i put it in angle and pushed against a tree and forced it to move, and no problem since lol
__________________
Walt
95 Jeep YJ 760 Speedwing
90 Dodge W250 CTD Blizzard 810
Harder Electri-Spread SS v box
1946 Oshkosh W-307 12' Viking one way, 8' Frink V
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:05 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.1