Fisher M/M won't go up - Snow Plow Forum - Let's Talk Snow Discussion Forums
 
LinkBack Thread Tools Display Modes
post #1 of 13 Old 01-28-2009, 03:44 PM Thread Starter
Member
 
Britt_Landscaping's Avatar
 
Join Date: Jan 2009
Location: Newport, NH
Posts: 33
Send a message via AIM to Britt_Landscaping Send a message via Yahoo to Britt_Landscaping
Fisher M/M won't go up

Sorry if this question has been asked! I'm in the middle of a snow storm and my Fisher M/M won't angle or go up. It was sticking a little when angling left earlier but now it won't go left or right or up. This sucks! Any suggestions? Thanks!

- Jake

Jake Britt

#1. '00 Chevy K3500 w/9' Fisher Plow, 10' Rugby Dump Body
#2. '86 GMC K1500HS w/7'6" Fisher Plow
#3. '69 Bolens 1220 Garden Tractor w/42" Snow Plow
#4. '76 Bolens G14 Garden Tractor w/38" Snow Blower
Britt_Landscaping is offline  
Sponsored Links
Advertisement
 
post #2 of 13 Old 01-28-2009, 03:50 PM
LetsTalkSnow.com - Addict
 
snowjoker's Avatar
 
Join Date: Nov 2003
Location: Waterport, NY
Posts: 3,380
Send a message via AIM to snowjoker
How is your fluid, perhaps frozen up ? Pump screen clean ?

Walt
95 Jeep YJ 760 Speedwing
90 Dodge W250 CTD Blizzard 810
Harder Electri-Spread SS v box
1946 Oshkosh W-307 12' Viking one way, 8' Frink V
snowjoker is offline  
post #3 of 13 Old 01-28-2009, 03:56 PM Thread Starter
Member
 
Britt_Landscaping's Avatar
 
Join Date: Jan 2009
Location: Newport, NH
Posts: 33
Send a message via AIM to Britt_Landscaping Send a message via Yahoo to Britt_Landscaping
Quote:
Originally Posted by snowjoker View Post
How is your fluid, perhaps frozen up ? Pump screen clean ?
It should be clean and the fluid should be fine, as it was just done a week ago. It's not that cold out either. The guy before me who bought it had problems and the dealer said water got into the fluid. They cleaned it out and all. I'm thinking maybe electrical? I'm not sure. Maybe it's what you said. First time owning a minute mount lol. I've only used older plow hitches.

I don't even know how to go about checking the pump screen, etc.

Jake Britt

#1. '00 Chevy K3500 w/9' Fisher Plow, 10' Rugby Dump Body
#2. '86 GMC K1500HS w/7'6" Fisher Plow
#3. '69 Bolens 1220 Garden Tractor w/42" Snow Plow
#4. '76 Bolens G14 Garden Tractor w/38" Snow Blower
Britt_Landscaping is offline  
post #4 of 13 Old 01-28-2009, 03:58 PM Thread Starter
Member
 
Britt_Landscaping's Avatar
 
Join Date: Jan 2009
Location: Newport, NH
Posts: 33
Send a message via AIM to Britt_Landscaping Send a message via Yahoo to Britt_Landscaping
I'll check the fluid. Is it possible to froze up while it's been in use for a couple hours? I've never had an under the hood hydraulic pump's fluid froze up on me (though I've had it run slow in really cold weather).

Jake Britt

#1. '00 Chevy K3500 w/9' Fisher Plow, 10' Rugby Dump Body
#2. '86 GMC K1500HS w/7'6" Fisher Plow
#3. '69 Bolens 1220 Garden Tractor w/42" Snow Plow
#4. '76 Bolens G14 Garden Tractor w/38" Snow Blower
Britt_Landscaping is offline  
post #5 of 13 Old 01-28-2009, 04:17 PM Thread Starter
Member
 
Britt_Landscaping's Avatar
 
Join Date: Jan 2009
Location: Newport, NH
Posts: 33
Send a message via AIM to Britt_Landscaping Send a message via Yahoo to Britt_Landscaping
The truck has been sitting for an hour or so now, and now the plow is working again. What would cause it to go from not working, and then shutting the truck off for a while, and the plow then works?

Jake Britt

#1. '00 Chevy K3500 w/9' Fisher Plow, 10' Rugby Dump Body
#2. '86 GMC K1500HS w/7'6" Fisher Plow
#3. '69 Bolens 1220 Garden Tractor w/42" Snow Plow
#4. '76 Bolens G14 Garden Tractor w/38" Snow Blower
Britt_Landscaping is offline  
post #6 of 13 Old 01-28-2009, 04:42 PM
LetsTalkSnow.com - Addict
 
snowjoker's Avatar
 
Join Date: Nov 2003
Location: Waterport, NY
Posts: 3,380
Send a message via AIM to snowjoker
if its a minute mount it should have electric over hydraulic power pack, or a conventional mount that has a belt drive system on it ? Service that pump, clean the inlet screen and put new fluid in it...

Walt
95 Jeep YJ 760 Speedwing
90 Dodge W250 CTD Blizzard 810
Harder Electri-Spread SS v box
1946 Oshkosh W-307 12' Viking one way, 8' Frink V
snowjoker is offline  
post #7 of 13 Old 01-28-2009, 04:43 PM Thread Starter
Member
 
Britt_Landscaping's Avatar
 
Join Date: Jan 2009
Location: Newport, NH
Posts: 33
Send a message via AIM to Britt_Landscaping Send a message via Yahoo to Britt_Landscaping
This plow is a minute mount.

Jake Britt

#1. '00 Chevy K3500 w/9' Fisher Plow, 10' Rugby Dump Body
#2. '86 GMC K1500HS w/7'6" Fisher Plow
#3. '69 Bolens 1220 Garden Tractor w/42" Snow Plow
#4. '76 Bolens G14 Garden Tractor w/38" Snow Blower
Britt_Landscaping is offline  
post #8 of 13 Old 01-28-2009, 04:52 PM
LetsTalkSnow.com - Addict
 
atgreene's Avatar
 
Join Date: Nov 2003
Location: Mud City, Sebago, Maine
Posts: 5,486
Send a message via AIM to atgreene
Like Walt said, pull the fluid resevoir. Get rid of the old fluid. Clean the screen or change the filter depending upon what it has, refill with new fluid (the good stuff). Repeat the entire process after using it for a couple hours. May require several flushings to get rid of the moisture.

Check to make sure the breather cap is there. If it's missing don't bother doing anything until you replace it.

If the problem is electrical, check all the connections on the grill, clean them and grease them with DIELECTRIC grease. Make sure connections at solenoid and pump are ok and then check all your grounds, ALL of them.

Good luck.

2013 GMC 3500 9 2 Boss V
2005 GMC 5500 Topkick 10' Boss V (For Sale) (SOLD)
1963 Oshkosh 10' V, 11' Wing (For Sale)
Kubota M7040, 8' pusher, 8' blower.
2005 Takeuchi 135
IAFF Local 740

Facebook: A. T. Greene Excavation & Snowplowing

www.atgreene.com
atgreene is offline  
post #9 of 13 Old 01-28-2009, 05:33 PM Thread Starter
Member
 
Britt_Landscaping's Avatar
 
Join Date: Jan 2009
Location: Newport, NH
Posts: 33
Send a message via AIM to Britt_Landscaping Send a message via Yahoo to Britt_Landscaping
Thank-you for the help everyone, I'll check it out and see what the problem is.

Jake Britt

#1. '00 Chevy K3500 w/9' Fisher Plow, 10' Rugby Dump Body
#2. '86 GMC K1500HS w/7'6" Fisher Plow
#3. '69 Bolens 1220 Garden Tractor w/42" Snow Plow
#4. '76 Bolens G14 Garden Tractor w/38" Snow Blower
Britt_Landscaping is offline  
post #10 of 13 Old 01-29-2009, 03:37 AM
Member
 
todddude's Avatar
 
Join Date: Jan 2008
Location: Central New York
Posts: 148
Maybe the other plow guy or your landlord sabotaged the plow at the apartment complex????? That will teach you to complain!!
todddude is offline  
post #11 of 13 Old 02-03-2009, 04:10 PM Thread Starter
Member
 
Britt_Landscaping's Avatar
 
Join Date: Jan 2009
Location: Newport, NH
Posts: 33
Send a message via AIM to Britt_Landscaping Send a message via Yahoo to Britt_Landscaping
I think it's the solenoid. We'll see how it comes out!

Jake Britt

#1. '00 Chevy K3500 w/9' Fisher Plow, 10' Rugby Dump Body
#2. '86 GMC K1500HS w/7'6" Fisher Plow
#3. '69 Bolens 1220 Garden Tractor w/42" Snow Plow
#4. '76 Bolens G14 Garden Tractor w/38" Snow Blower
Britt_Landscaping is offline  
post #12 of 13 Old 02-23-2009, 04:33 PM
Junior Member
 
Join Date: Dec 2006
Location: wallingford CT
Posts: 16
I had the same problum It was my connections. I cleaned them real good and put di eletric grease.
Q RIVER is offline  
post #13 of 13 Old 03-01-2009, 04:22 PM
Junior Member
 
Join Date: Nov 2008
Location: fall river mass.
Posts: 12
Exclamation brand new mm2 wont angle

fixing to get a foot of snow tonight have a brand new mm2 goes up down angles left no problem wont angle right plow has never been used and stays in garage
checked fluid full tried to bleed cylinder very little air now im out of daylight and ideas plus its cold inhere any help appreciated
newbie1276 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snow Plow Forum - Let's Talk Snow Discussion Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome